summaryrefslogtreecommitdiff
path: root/src/core/settings/plugins/ifcfg-rh/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/settings/plugins/ifcfg-rh/tests/meson.build')
-rw-r--r--src/core/settings/plugins/ifcfg-rh/tests/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/core/settings/plugins/ifcfg-rh/tests/meson.build b/src/core/settings/plugins/ifcfg-rh/tests/meson.build
new file mode 100644
index 0000000000..077e4782f0
--- /dev/null
+++ b/src/core/settings/plugins/ifcfg-rh/tests/meson.build
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+exe = executable(
+ 'test-ifcfg-rh',
+ 'test-ifcfg-rh.c',
+ dependencies: libNetworkManagerTest_dep,
+ c_args: test_c_flags,
+ link_with: libnms_ifcfg_rh_core,
+)
+
+test(
+ 'ifcfg-rh/test-ifcfg-rh',
+ test_script,
+ timeout: 90,
+ args: test_args + [exe.full_path()],
+)