summaryrefslogtreecommitdiff
path: root/src/core/ndisc/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/ndisc/tests/meson.build')
-rw-r--r--src/core/ndisc/tests/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/core/ndisc/tests/meson.build b/src/core/ndisc/tests/meson.build
new file mode 100644
index 0000000000..6a2e70f08c
--- /dev/null
+++ b/src/core/ndisc/tests/meson.build
@@ -0,0 +1,26 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+test_unit = 'test-ndisc-fake'
+
+exe = executable(
+ test_unit,
+ test_unit + '.c',
+ dependencies: libNetworkManagerTest_dep,
+ c_args: test_c_flags,
+)
+
+test(
+ 'ndisc/' + test_unit,
+ test_script,
+ args: test_args + [exe.full_path()],
+ timeout: default_test_timeout,
+)
+
+test = 'test-ndisc-linux'
+
+exe = executable(
+ test,
+ test + '.c',
+ dependencies: libNetworkManagerTest_dep,
+ c_args: test_c_flags,
+)