summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7e641cb..4f0c85d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,9 @@
AC_PREREQ([2.68])
-AC_INIT([ConsoleKit],[0.4.6],[https://bugs.freedesktop.org/enter_bug.cgi?product=ConsoleKit],[ConsoleKit])
+AC_INIT([ConsoleKit],
+ [0.4.6],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=ConsoleKit],
+ [ConsoleKit])
AC_CONFIG_SRCDIR([src/ck-manager.c])
@@ -368,10 +371,9 @@ AC_SUBST(LDFLAGS)
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
- [],
- [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
-AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
-AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+AS_IF([test "x$with_systemdsystemunitdir" != "xno"], [ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])])
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != "xno"])
# Files