summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-10-16 10:01:13 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-10-20 13:32:16 +1000
commit010d5e28655d619693632938e9e4325eef938295 (patch)
treead1ee0465e7fb44962ae7d09b662613c470ed505 /configure.ac
parentff3e171568c8b604fc5eacd5f7e9b7ee9417f172 (diff)
dmx: remove doxygen-generated files.
These can be recreated by simply running 'doxygen doxygen.conf' in hw/dmx/doc. Some of the files do not exist anymore, these have been removed. Some other files have a different naming scheme. Doxygen warnings about missing links fixed, two warnings remain: /home/whot/xorg/xserver/hw/dmx/dmxwindow.c:142: Warning: explicit link request to 'dmxConfigureRootWindow' could not be resolved /home/whot/xorg/xserver/hw/dmx/dmxwindow.c:119: Warning: explicit link request to 'dmxConfigureScreenWindow()' could not be resolved Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c4465d2a3..93cc70abe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1846,6 +1846,13 @@ dnl Linux sources in DMX require <linux/keyboard.h>
AC_SUBST(XRESEXAMPLES_DEP_LIBS)
PKG_CHECK_MODULES([X11EXAMPLES_DEP], [$LIBXEXT x11])
AC_SUBST(X11EXAMPLES_DEP_LIBS)
+
+ AC_PATH_PROG(DOXYGEN,doxygen,[not_found])
+ if test "x$DOXYGEN" = "xnot_found" ; then
+ AC_MSG_WARN([doxygen not found in $PATH. Cannot build documentation])
+ fi
+ AM_CONDITIONAL([HAVE_DOXYGEN], [test "x$DOXYGEN" != "xnot_found"])
+ AC_SUBST(DOXYGEN)
fi
AM_CONDITIONAL([DMX_BUILD_LNX], [test "x$DMX_BUILD_LNX" = xyes])
AM_CONDITIONAL([DMX_BUILD_USB], [test "x$DMX_BUILD_USB" = xyes])