summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2008-01-09 13:53:21 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2008-01-09 13:53:21 +0000
commitf73b18abe506673dec5e09d55a93ac4f11731f08 (patch)
tree3697ffb8bd0c0c192146401cc0f243bc3229c99a /Makefile.am
parent412c01ca8d9dd67229bcada2740f52d0057fdd0a (diff)
Makefile.am: Include lcov.mak to allow building coverage reports. Add top-level check targets similar to other gst pa...
Original commit message from CVS: * Makefile.am: Include lcov.mak to allow building coverage reports. Add top-level check targets similar to other gst packages.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b2e3f6d5..d7a9ef2ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,15 @@ include $(top_srcdir)/common/release.mak
include $(top_srcdir)/common/po.mak
check-valgrind:
- @true
+ cd tests/check && make check-valgrind
+if HAVE_GST_CHECK
check-torture:
- @true
+ cd tests/check && make torture
+else
+check-torture:
+ true
+endif
+
+include $(top_srcdir)/common/coverage/lcov.mak
+