summaryrefslogtreecommitdiff
path: root/hw/Makefile.am
diff options
context:
space:
mode:
authorBen Byer <bbyer@apple.com>2007-02-17 01:21:43 -0800
committerBen Byer <bbyer@apple.com>2007-02-17 01:21:43 -0800
commitcf4994b0db2fef4c10ce8804adef766bc5118daf (patch)
treee70a409a9df6da1132c4ccef339e3f112e7d12a1 /hw/Makefile.am
parentcece0601571f6304e392a3a40505664544b249f3 (diff)
dix mods for Darwin
Diffstat (limited to 'hw/Makefile.am')
-rw-r--r--hw/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/hw/Makefile.am b/hw/Makefile.am
index d00d6fb3f..99df8e230 100644
--- a/hw/Makefile.am
+++ b/hw/Makefile.am
@@ -1,10 +1,18 @@
if DMX
+if BUILD_DARWIN
+# Darwin does not need the dmx subdir
+else
DMX_SUBDIRS = dmx
endif
+endif
if XORG
+if BUILD_DARWIN
+# Darwin does not need the xfree86 subdir
+else
XORG_SUBDIRS = xfree86
endif
+endif
if XVFB
XVFB_SUBDIRS = vfb
@@ -30,12 +38,15 @@ if XPRINT
XPRINT_SUBDIRS = xprint
endif
-# need to add darwin support here
+if BUILD_DARWIN
+DARWIN_SUBDIRS = darwin
+endif
SUBDIRS = \
$(XORG_SUBDIRS) \
$(XGL_SUBDIRS) \
$(XWIN_SUBDIRS) \
+ $(DARWIN_SUBDIRS) \
$(XVFB_SUBDIRS) \
$(XNEST_SUBDIRS) \
$(DMX_SUBDIRS) \