summaryrefslogtreecommitdiff
path: root/Xi/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2008-07-07 22:10:17 +0930
committerPeter Hutterer <peter.hutterer@who-t.net>2008-07-10 16:28:34 +0930
commit2039c6ea43244339659323d05d96c14e41996c20 (patch)
tree9f396ab16102d5b9199c439b39a087c8afd5247a /Xi/Makefile.am
parent4ab01fe5db7fb330b1ec463aa49b77859527e597 (diff)
Xi: add support for input device properties.
Basically just copied from randr properties, with minor changes only. Each device supports arbitrary properties that can be modified by clients. Modifications to the properties are passed to the driver (if applicable) and can then affect the configuration of the device. Note that device properties are limited to a specific device. A property set on a slave device does not migrate to the master.
Diffstat (limited to 'Xi/Makefile.am')
-rw-r--r--Xi/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Xi/Makefile.am b/Xi/Makefile.am
index 2af1940eb..768f996cc 100644
--- a/Xi/Makefile.am
+++ b/Xi/Makefile.am
@@ -94,7 +94,9 @@ libXi_la_SOURCES = \
ungrdevk.h \
warpdevp.c \
warpdevp.h \
- xiselev.c \
- xiselev.h
+ xiproperty.c \
+ xiproperty.h \
+ xiselev.c \
+ xiselev.h
EXTRA_DIST = stubs.c