summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2006-02-16 07:17:31 +0000
committerKeith Packard <keithp@keithp.com>2006-02-16 07:17:31 +0000
commit8987b2c1efc9a4667e278e6ba411772ba2a4a4e6 (patch)
treeeb7aa732b0f74c958770e26717679c8e893449bc /Makefile.am
parentc8acb342695936db062c966029019a458d45459e (diff)
Make more extensions optional in build (for kdrive). Fix kdrive build for
actual hardware. Fix kdrive pointer signed/unsigned types. Add kdrive-required YX rotation functions. Replace rgb text file loading with static rgb color table.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 51145ebd7..d8ca377fb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,14 @@ if LBX
LBX_DIR=lbx
endif
+if XINPUT
+XINPUT_DIR=Xi
+endif
+
+if DBE
+DBE_DIR=dbe
+endif
+
SUBDIRS = \
doc \
include \
@@ -46,9 +54,9 @@ SUBDIRS = \
os \
randr \
render \
- Xi \
+ $(XINPUT_DIR) \
xkb \
- dbe \
+ $(DBE_DIR) \
$(MFB_DIR) \
$(AFB_DIR) \
$(CFB_DIR) \