summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-08-21 19:15:11 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-08-21 19:15:11 +0000
commit588105173840355717d7b2f7f652289a41166c3f (patch)
tree5b40793196c6254275d761fb6d24dc7e895f429c /Makefile.am
parent367f45073953f8f99a2d9dd054f479e1070f856e (diff)
Huge cleanup. Group into sections: hardware feature detection, extension
detection/configuration, DDX options. Make building of Xorg DDX fully optional. Clarify and correct some help texts. Change all comments to use dnl instead of #. Quote all tests correctly, and guard pure-variable tests with 'x' (e.g. test $DMX = yes -> test "x$DMX" = xyes). Since the DDXes seem to have pretty divergent extension support these days, get rid of EXTENSION_LIBS, DMX_EXTENSIONS and XPRINT_EXTENSIONS, and go back to building extension lists by hand in the DDX-specific sections. Use portable POSIX constructs everywhere (e.g. test foo && test bar, instead of test foo -a bar). Clean up old cruft. Set _XSERVER64 on 64-bit architectures, and use x86_64 for host_cpu instead of amd64 (Jürg Billeter).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4118871df..c1a8738f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,21 +3,26 @@ AUTOMAKE_OPTIONS=dist-bzip2 foreign nostdinc
if COMPOSITE
COMPOSITE_DIR=composite
endif
+
if XTRAP
XTRAP_DIR=XTrap
endif
+
if CFB
CFB_DIR=cfb
CFB16_DIR=cfb16
CFB24_DIR=cfb24
CFB32_DIR=cfb32
endif
+
if AFB
AFB_DIR=afb
endif
+
if MFB
MFB_DIR=mfb
endif
+
if GLX
GLX_DIR=GL
endif