summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..e9ba15c
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,22 @@
+all: html
+install-data-local: install-html
+
+VDPAU_HEADER_DIR := $(top_srcdir)/include
+VDPAU_HEADER_FILES := \
+ $(VDPAU_HEADER_DIR)/vdpau/vdpau.h \
+ $(VDPAU_HEADER_DIR)/vdpau/vdpau_x11.h
+
+export VDPAU_HEADER_DIR
+export VDPAU_HEADER_FILES
+html-out/%: Doxyfile $(VDPAU_HEADER_FILES)
+ $(DOXYGEN) $<
+
+if ENABLE_DOCS
+html: html-out/index.html
+install-html-local:
+ $(install_sh) -d $(DESTDIR)$(docdir)/html
+ $(install_sh) -m 644 html-out/* $(DESTDIR)$(docdir)/html
+endif
+
+clean-local:
+ $(RM) -r html-out