summaryrefslogtreecommitdiff
path: root/hw/xquartz/bundle/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xquartz/bundle/Makefile.am')
-rw-r--r--hw/xquartz/bundle/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/hw/xquartz/bundle/Makefile.am b/hw/xquartz/bundle/Makefile.am
index 03fa1ddb1..963327bb9 100644
--- a/hw/xquartz/bundle/Makefile.am
+++ b/hw/xquartz/bundle/Makefile.am
@@ -5,7 +5,10 @@ CPP_FILES_FLAGS = \
-DAPPLE_APPLICATION_NAME="$(APPLE_APPLICATION_NAME)"
install-data-hook:
- ./mk_bundke.sh $(DESTDIR)$(APPLE_APPLICATIONS_DIR)/$(APPLE_APPLICATION_NAME).app
+ $(srcdir)/mk_bundke.sh $(srcdir) $(builddir) $(DESTDIR)$(APPLE_APPLICATIONS_DIR)/$(APPLE_APPLICATION_NAME).app install
+
+uninstall-hook:
+ $(RM) -rf $(DESTDIR)$(APPLE_APPLICATIONS_DIR)/$(APPLE_APPLICATION_NAME).app
noinst_PRE = Info.plist.cpp
noinst_DATA = $(noinst_PRE:plist.cpp=plist)