summaryrefslogtreecommitdiff
path: root/hw/xquartz/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@freedesktop.org>2008-11-14 14:57:09 -0800
committerJeremy Huddleston <jeremyhu@freedesktop.org>2008-11-14 15:10:32 -0800
commitb0789365719f48c0b477b4703f2072f932246b76 (patch)
treed57274bf8a991712cf7b224a31c7f210cf642d7c /hw/xquartz/Makefile.am
parent1d7049f8fd3c0798250b9213149d3ce0b37ab77f (diff)
XQuartz: Initial work on readding GLX to the 1.5 server
(cherry picked from commit a186cab6ae82340770c13b37ff5df731ce2a0ceb)
Diffstat (limited to 'hw/xquartz/Makefile.am')
-rw-r--r--hw/xquartz/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/hw/xquartz/Makefile.am b/hw/xquartz/Makefile.am
index 782321e08..cc1ff833b 100644
--- a/hw/xquartz/Makefile.am
+++ b/hw/xquartz/Makefile.am
@@ -9,8 +9,13 @@ AM_CPPFLAGS = \
-DXFree86Server \
-I$(top_srcdir)/miext/rootless
-# GL
-SUBDIRS = bundle . xpr mach-startup doc pbproxy
+if GLX
+GL_DIR = GL
+endif
+
+SUBDIRS = bundle . GL xpr mach-startup doc pbproxy
+
+DIST_SUBDIRS = bundle . $(GL_DIR) xpr mach-startup doc pbproxy
libXquartz_la_SOURCES = \
$(top_srcdir)/fb/fbcmap_mi.c \