summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2008-08-18 09:53:48 -0400
committerAdam Jackson <ajax@redhat.com>2008-08-18 09:53:48 -0400
commite1ae8db625b5e8c298a557592ef23656b3da4886 (patch)
tree1f657239f19cf027d4fd44cdc031248953949f82 /configure.ac
parent99583b43a9a202d047ff417d47485e4c0e0c9670 (diff)
Drop dead PowerPC PCI code.
Also add a warning for anyone still using legacy PCI code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index d42d7fd45..95a084f42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1217,7 +1217,6 @@ AC_MSG_RESULT([$XORG])
xorg_bus_linuxpci=no
xorg_bus_bsdpci=no
xorg_bus_ix86pci=no
-xorg_bus_ppcpci=no
xorg_bus_sparcpci=no
xorg_bus_sparc=no
@@ -1344,15 +1343,6 @@ if test "x$XORG" = xyes; then
esac
case $host_cpu in
- powerpc*)
- case $host_os in
- linux*|freebsd*|netbsd*|openbsd*|kfreebsd*-gnu)
- ;;
- *)
- xorg_bus_ppcpci="yes"
- ;;
- esac
- ;;
sparc*)
xorg_bus_sparcpci="yes"
xorg_bus_sparc="yes"
@@ -1460,7 +1450,6 @@ AM_CONDITIONAL([XORG], [test "x$XORG" = xyes])
AM_CONDITIONAL([XORG_BUS_LINUXPCI], [test "x$xorg_bus_linuxpci" = xyes])
AM_CONDITIONAL([XORG_BUS_BSDPCI], [test "x$xorg_bus_bsdpci" = xyes])
AM_CONDITIONAL([XORG_BUS_IX86PCI], [test "x$xorg_bus_ix86pci" = xyes])
-AM_CONDITIONAL([XORG_BUS_PPCPCI], [test "x$xorg_bus_ppcpci" = xyes])
AM_CONDITIONAL([XORG_BUS_SPARCPCI], [test "x$xorg_bus_sparcpci" = xyes])
AM_CONDITIONAL([XORG_BUS_SPARC], [test "x$xorg_bus_sparc" = xyes])
AM_CONDITIONAL([LINUX_IA64], [test "x$linux_ia64" = xyes])