summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6757a6f..13a7d94 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,2 +30,3 @@ if LINUX
OS_SUPPORT = linux_sysfs.c linux_devmem.c linux_devmem.h
+VGA_ARBITER = common_vgaarb.c
endif
@@ -34,2 +35,3 @@ if FREEBSD
OS_SUPPORT = freebsd_pci.c
+VGA_ARBITER = common_vgaarb_stub.c
endif
@@ -38,2 +40,3 @@ if NETBSD
OS_SUPPORT = netbsd_pci.c
+VGA_ARBITER = common_vgaarb_stub.c
endif
@@ -42,2 +45,3 @@ if OPENBSD
OS_SUPPORT = openbsd_pci.c
+# VGA Arbiter code is included in openbsd_pci.c
endif
@@ -46,7 +50,2 @@ if SOLARIS
OS_SUPPORT = solx_devfs.c pci_tools.h
-endif
-
-if LINUX
-VGA_ARBITER = common_vgaarb.c
-else
VGA_ARBITER = common_vgaarb_stub.c
@@ -56,2 +55,3 @@ if GNU
OS_SUPPORT = x86_pci.c
+VGA_ARBITER = common_vgaarb_stub.c
endif