summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 426e178..c576e98 100755
--- a/configure.ac
+++ b/configure.ac
@@ -38,2 +38,11 @@ AM_PROG_CC_C_O
+if test x"$CC_FOR_BUILD" = x; then
+ test x"$cross_compiling" = xyes; then
+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
+ else
+ CC_FOR_BUILD="$CC"
+ fi
+fi
+AC_SUBST([CC_FOR_BUILD])
+
PKG_CHECK_MODULES(XT, sm x11 xproto kbproto)