summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 0 insertions, 38 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 534c3fd..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,38 +0,0 @@
1# Copyright 2007 Luc Verhaegen <libv@exsuse.de>
2# Copyright 2007 Matthias Hopf <mhopf@novell.com>
3# Copyright 2007 Egbert Eich <eich@novell.com>
4# Copyright 2007 Advanced Micro Devices, Inc.
5#
6# Permission is hereby granted, free of charge, to any person obtaining a
7# copy of this software and associated documentation files (the "Software"),
8# to deal in the Software without restriction, including without limitation
9# the rights to use, copy, modify, merge, publish, distribute, sublicense,
10# and/or sell copies of the Software, and to permit persons to whom the
11# Software is furnished to do so, subject to the following conditions:
12#
13# The above copyright notice and this permission notice shall be included in
14# all copies or substantial portions of the Software.
15#
16# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
17# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
18# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
19# THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
20# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
21# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
22# OTHER DEALINGS IN THE SOFTWARE.
23
24AUTOMAKE_OPTIONS = foreign
25# src before man: src/ may update sources in man/
26SUBDIRS = src man utils/conntest
27
28EXTRA_DIST = RadeonHD.tmpl Imakefile git_version.sh ChangeLog INSTALL
29MAINTAINERCLEANFILES = ChangeLog
30
31.PHONY: ChangeLog
32
33# "git log" with the space should be available since git 1.3.0
34ChangeLog:
35 (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
36
37dist-hook: ChangeLog
38