summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJamey Sharp <jamey@minilop.net>2006-11-24 13:24:05 -0800
committerJosh Triplett <josh@freedesktop.org>2006-11-25 23:47:51 -0800
commit978e8839cbd822f80c3236fa30d080574ff43b8d (patch)
tree2f0f7855c506168073f62aaea36dfecf9e2258a2
parentfe12aa7dbf9f81a17edfe89f72d30810a99af7fb (diff)
NetBSD doesn't have AI_ADDRCONFIG: use it only if it's available.
(cherry picked from commit 3360d0c79e98cf6b7f30b2d84f117aea0a28595d)
-rw-r--r--debian/changelog2
-rw-r--r--src/xcb_util.c5
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6609c93..43a2e59 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ libxcb (1.0-1) experimental; urgency=low
check first started shipping the pkg-config file.
* Add Build-Depends on libpthread-stubs0-dev.
* Add XS-Vcs-Git field.
+ * Cherry-pick post-1.0 changes from master:
+ * "NetBSD doesn't have AI_ADDRCONFIG: use it only if it's available."
-- Josh Triplett <josh@freedesktop.org> Fri, 24 Nov 2006 00:51:41 -0800
diff --git a/src/xcb_util.c b/src/xcb_util.c
index bd9f2b5..eeee1dd 100644
--- a/src/xcb_util.c
+++ b/src/xcb_util.c
@@ -176,7 +176,10 @@ static int _xcb_open_decnet(const char *host, const unsigned short port)
static int _xcb_open_tcp(char *host, const unsigned short port)
{
int fd = -1;
- struct addrinfo hints = { AI_ADDRCONFIG
+ struct addrinfo hints = { 0
+#ifdef AI_ADDRCONFIG
+ | AI_ADDRCONFIG
+#endif
#ifdef AI_NUMERICSERV
| AI_NUMERICSERV
#endif