summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2015-06-13 09:50:14 -0700
committerDan Nicholson <dbn.lists@gmail.com>2015-06-13 09:50:14 -0700
commitd377ee6b740373895cb67cdc14a98c0d71650e05 (patch)
treeba1f319d6f49527a53e24fb5d7c2a2257078c2ab /Makefile.am
parent40342dd0ead05d457a2a4e692cf865f50033a709 (diff)
build: Force linking of host tool
In case a reinstall is being performed, ensure than an existing host tool is overwritten. https://bugs.freedesktop.org/show_bug.cgi?id=90437
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f64e2cd..6dc5b39 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,7 +41,7 @@ pkg_config_SOURCES= \
if HOST_TOOL
host_tool = $(host)-pkg-config$(EXEEXT)
install-exec-hook:
- cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
+ cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
uninstall-hook:
cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
endif