summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2012-06-06 00:26:02 +0200
committerFridrich Štrba <fridrich.strba@bluewin.ch>2012-06-06 00:26:02 +0200
commit800447ddac2360fdbd1e4d77e8e0ab9f36b26b81 (patch)
tree43e0a847c8180a194aa933abff3fb315626f5494 /configure.ac
parent09f410712011396119b476b78d628d123c776480 (diff)
Warn a bit more in order to have the LO build a bit easier
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 991e68a..27f151f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,13 +141,13 @@ AS_IF([test "x$native_win32" = "xyes"], [
AC_MSG_WARN([produced libraries might be incompatible with MSVC-compiled code])
])
])
- CFLAGS="$CFLAGS -Wall -pedantic"
- CXXFLAGS="$CXXFLAGS -Wall -pedantic"
+ CFLAGS="$CFLAGS -Wall -Wshadow -pedantic"
+ CXXFLAGS="$CXXFLAGS -Wall -Wshadow -pedantic"
], [
AS_IF([test x"$GCC" = xyes], [
# Be tough with warnings and produce less careless code
- CFLAGS="$CFLAGS -Wall -pedantic"
- CXXFLAGS="$CXXFLAGS -Wall -pedantic -Weffc++"
+ CFLAGS="$CFLAGS -Wall -Wextra -pedantic"
+ CXXFLAGS="$CXXFLAGS -Wall -Wextra -pedantic -Weffc++"
])
])
AC_SUBST(DEBUG_CXXFLAGS)