summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2012-02-10 14:58:29 +0100
committerMiklos Vajna <vmiklos@frugalware.org>2012-02-10 15:57:25 +0100
commit848b0b4bf8fb5407cb4fecdc0d3238dbef8596e3 (patch)
tree68a865326e7905ec22a59f4e7f8f3e25195a5ea8 /configure.in
parente1fef2029dc2551470f356738ab45c43fd3f9d6c (diff)
use system stdlibs on Linux by default (fdo#45074, fdo#45696)
The old system libraries breaked 3rd-party extensions. There were also problems with exceptions hadnling. We use pretty old compiler for the official build, so it should be compatible with most systems. It is the preferred default also for other distro builds. Signed-off-by: Miklos Vajna <vmiklos@frugalware.org>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 109bc7d04253..4667f0b4cda7 100644
--- a/configure.in
+++ b/configure.in
@@ -933,8 +933,8 @@ AC_ARG_WITH(system-jars,
,)
AC_ARG_WITH(system-stdlibs,
- AS_HELP_STRING([--with-system-stdlibs],
- [Use libstdc++/libgcc_s already on system.]),,
+ AS_HELP_STRING([--without-system-stdlibs],
+ [Bundle the used libstdc++/libgcc_s into the installation set.]),,
[with_system_stdlibs="$with_system_libs"])
AC_ARG_WITH(system-cairo,
@@ -4653,7 +4653,7 @@ dnl ===================================================================
dnl Check for system stdlibs
dnl ===================================================================
AC_MSG_CHECKING([whether to provide libstdc++/libgcc_s in the installset])
-if test "$with_system_stdlibs" = "yes"; then
+if test "$with_system_stdlibs" != "no"; then
AC_MSG_RESULT([no])
SYSTEM_STDLIBS=YES
else