summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-09-20 08:01:13 +0200
committerStephan Bergmann <sbergman@redhat.com>2016-09-20 07:34:01 +0000
commit8af35c9590262965c603d8609b57cc76d23e8506 (patch)
tree2f9f10ec1810172792c95b8ee645bfe525b6f3f1 /configure.ac
parent63e034326b56f6c8696ac1d82a32ae8fbffdba2a (diff)
Remove obsolete HAVE_GCC_VISIBILITY_FEATURE check
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=19664> "libstdc++ headers should have pop/push of the visibility around the declarations" (aka gcc#22482, rhbz#162935) is fixed ever since GCC 4.2. Make this a fatal configure error for now. The check should be removed completely after LO 5.3 branch-off. Change-Id: I3e8fde187b4b20652ee3164485ef868a9bf5a7ce Reviewed-on: https://gerrit.libreoffice.org/29071 Tested-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f4b91fb838a9..37d51458fcdb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6494,9 +6494,7 @@ if test \( "$_os" != "WINNT" -o "$WITH_MINGW" = "yes" \); then
AC_EGREP_HEADER(visibility push, string, stlvisok=yes, stlvisok=no)
AC_MSG_RESULT([$stlvisok])
if test "$stlvisok" = "no"; then
- AC_MSG_WARN([Your libstdc++ headers are not visibility safe. Disabling visibility])
- add_warning "Your libstdc++ headers are not visibility safe. Disabling visibility"
- unset HAVE_GCC_VISIBILITY_FEATURE
+ AC_MSG_ERROR([Your libstdc++ headers are not visibility safe. This is no longer supported.])
fi
fi