summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-09-20 08:06:25 +0200
committerStephan Bergmann <sbergman@redhat.com>2016-09-20 07:34:10 +0000
commit60b6b1eae563c727160724a8671844bf8136f5d5 (patch)
treeda870f1b29418809395149e3bd779a9d400e21e9 /configure.ac
parent8af35c9590262965c603d8609b57cc76d23e8506 (diff)
Remove obsolete HAVE_GCC_VISIBILITY_FEATURE check
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=26905> "default-visibility class symbol improperly resolved as hidden-visibility" is fixed ever since GCC 4.2. Make this a fatal configure error for now. The check should be removed completely after LO 5.3 branch-off. Change-Id: Ie365d5a0e2217a4efd1e8e2642963738ae7d20b1 Reviewed-on: https://gerrit.libreoffice.org/29072 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 37d51458fcdb..ae9e83ba9429 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6608,9 +6608,7 @@ _ACEOF
AC_MSG_RESULT([$gccvisbroken])
if test "$gccvisbroken" = "yes"; then
- AC_MSG_WARN([Your gcc is not -fvisibility=hidden safe. Disabling visibility])
- add_warning "Your gcc is not -fvisibility=hidden safe. Disabling visibility"
- unset HAVE_GCC_VISIBILITY_FEATURE
+ AC_MSG_ERROR([Your gcc is not -fvisibility=hidden safe. This is no longer supported.])
fi
fi