summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2015-11-30 21:19:52 +0100
committerMichael Stahl <mstahl@redhat.com>2015-12-02 11:13:20 +0100
commit76cd776207ef13d58a7cac838282c0ad2d65bcb8 (patch)
treecd76b1b09c7d5862873817613d4d02c48a510920 /configure.ac
parent63ada88a0fe28440c021141da911f69f7394250d (diff)
configure: check for dlsym(), not dlopen()
On Fedora 23, the check for dlopen happens to succeed with gcc -m32 -fsanitize=address, and then linking executables fails due to not finding dlsym. Checking for dlsym results in the proper -ldl. Change-Id: I02108c2c053e07b33848af068937f29967e7dc6a (cherry picked from commit 037584cfe5e58bf6807fb0188d245042baa8c1c0)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4d63038fd3cc..71e209010323 100644
--- a/configure.ac
+++ b/configure.ac
@@ -900,9 +900,9 @@ AC_SUBST(PTHREAD_LIBS)
if test $_os != "WINNT"; then
save_LIBS="$LIBS"
- AC_SEARCH_LIBS([dlopen], [dl],
- [case "$ac_cv_search_dlopen" in -l*) DLOPEN_LIBS="$ac_cv_search_dlopen";; esac],
- [AC_MSG_ERROR([dlopen not found in either libc nor libdl])])
+ AC_SEARCH_LIBS([dlsym], [dl],
+ [case "$ac_cv_search_dlsym" in -l*) DLOPEN_LIBS="$ac_cv_search_dlsym";; esac],
+ [AC_MSG_ERROR([dlsym not found in either libc nor libdl])])
LIBS="$save_LIBS"
fi
AC_SUBST(DLOPEN_LIBS)