summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomáš Chvátal <tomas.chvatal@gmail.com>2015-04-16 10:13:06 +0200
committerCaolán McNamara <caolanm@redhat.com>2015-04-21 13:07:16 +0000
commit697804f48f4217dab145d96175c6cddf560ec614 (patch)
tree38db3524da1e36be721df574e15a859ccb3f2945 /configure.ac
parentbd969ed90302655d41743e67124aef7101c99763 (diff)
Make cpp/poppler-version.h header optional
Older popler (SLE11) does not have this header yet. With the code simply if the header not found define version to oldest possible working candidate and also raise the .pc check to the same. Change-Id: I039c879879188fe2eb90cd119b80a1d6354a6a9c Reviewed-on: https://gerrit.libreoffice.org/15339 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 38e2beb57c1b..0d492ad38dd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10434,14 +10434,15 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
if test "$with_system_poppler" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_POPPLER=TRUE
- PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
+ PKG_CHECK_MODULES( POPPLER, poppler >= 0.12.0 )
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
save_CPPFLAGS=$CPPFLAGS
CXXFLAGS="$CXXFLAGS $POPPLER_CFLAGS"
CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
- AC_CHECK_HEADER([cpp/poppler-version.h], [],
- [AC_MSG_ERROR([cpp/poppler-version.h not found. Install poppler])], [])
+ AC_CHECK_HEADER([cpp/poppler-version.h],
+ [AC_DEFINE([HAVE_POPPLER_VERSION_H], 1)],
+ [])
CXXFLAGS=$save_CXXFLAGS
CPPFLAGS=$save_CPPFLAGS
AC_LANG_POP([C++])
@@ -10451,6 +10452,7 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
AC_MSG_RESULT([internal])
SYSTEM_POPPLER=
BUILD_TYPE="$BUILD_TYPE POPPLER"
+ AC_DEFINE([HAVE_POPPLER_VERSION_H], 1)
fi
else
AC_MSG_RESULT([no])
@@ -13004,6 +13006,7 @@ AC_CONFIG_HEADERS([config_host/config_vcl.h])
AC_CONFIG_HEADERS([config_host/config_vclplug.h])
AC_CONFIG_HEADERS([config_host/config_version.h])
AC_CONFIG_HEADERS([config_host/config_oauth2.h])
+AC_CONFIG_HEADERS([config_host/config_poppler.h])
AC_OUTPUT
if test "$CROSS_COMPILING" = TRUE; then