summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2015-04-01 09:15:44 +0200
committerMiklos Vajna <vmiklos@collabora.co.uk>2015-04-01 09:16:11 +0200
commit427ef167e1a49ba7fcdef082de43622e02a84ce5 (patch)
treefad076d3760c193b6581beea6283e60cf4afed74 /configure.ac
parentb49abbbd9d0107bef93adde32a1b51c78b6df469 (diff)
configure: check for validators if --with-export-validation is used
Change-Id: I535669e46f2535f0a0c0b106b964bfbc3a2e2d7e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f5c27f81dd24..0dbf5ac9e91a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2723,6 +2723,15 @@ AC_MSG_CHECKING([whether to enable export file validation])
if test "$with_export_validation" = yes; then
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_EXPORT_VALIDATION)
+
+ AC_CHECK_PROGS(ODFVALIDATOR, odfvalidator)
+ if test -z "$ODFVALIDATOR"; then
+ AC_MSG_ERROR([odfvalidator is not found in PATH, but required by --with-export-validation])
+ fi
+ AC_CHECK_PROGS(OFFICEOTRON, officeotron)
+ if test -z "$OFFICEOTRON"; then
+ AC_MSG_ERROR([officeotron is not found in PATH, but required by --with-export-validation])
+ fi
else
AC_MSG_RESULT([no])
fi