summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-05-31 15:24:34 +0200
committerMichael Stahl <mstahl@redhat.com>2013-06-01 00:47:21 +0200
commitd2c26bafc7675080c9cd65ac9844ae39497bd37f (patch)
treed6421a9a3abf8b84ec53c63ce751751d846a5107 /configure.ac
parent9853280211974d20b519624c16b2e7e6f76e7400 (diff)
configure: use -isystem for GSTREAMER_CFLAGS
... to work around GCC 4.8.0 -Werror=literal-suffix in gst/video/video.h definition of GST_VIDEO_CAPS_RGB8_PALETTED. Change-Id: I514b29d58f348bad0b13c7ef66db4b3ee34516cd (cherry picked from commit 18b0bda1be62da1b0f9c1fc40864ccc486d5b43c)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1818f2ca5577..c31a2872194b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9513,6 +9513,7 @@ if test "$build_gstreamer" = "yes"; then
ENABLE_GSTREAMER="TRUE"
AC_MSG_RESULT([yes])
PKG_CHECK_MODULES( GSTREAMER, gstreamer-1.0 gstreamer-plugins-base-1.0 gstreamer-video-1.0 )
+ GSTREAMER_CFLAGS="`echo $GSTREAMER_CFLAGS | sed -e \"s/-I/${ISYSTEM}/g\"`"
else
AC_MSG_RESULT([no])
fi
@@ -9532,6 +9533,7 @@ if test "$build_gstreamer_0_10" = "yes"; then
PKG_CHECK_MODULES( [GSTREAMER_0_10], [gstreamer-0.10 gstreamer-plugins-base-0.10 gstreamer-interfaces-0.10],, [
PKG_CHECK_MODULES( [GSTREAMER_0_10], [gstreamer-0.10 gstreamer-plugins-base-0.10] )
])
+ GSTREAMER_0_10_CFLAGS="`echo $GSTREAMER_0_10_CFLAGS | sed -e \"s/-I/${ISYSTEM}/g\"`"
else
AC_MSG_RESULT([no])
fi