summaryrefslogtreecommitdiff
path: root/ext/dash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/dash/Makefile.am')
-rw-r--r--ext/dash/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/ext/dash/Makefile.am b/ext/dash/Makefile.am
index 97d8623ec..32964bb15 100644
--- a/ext/dash/Makefile.am
+++ b/ext/dash/Makefile.am
@@ -13,10 +13,18 @@ noinst_HEADERS = \
gstdash_debug.h
# compiler and linker flags used to compile this plugin, set in configure.ac
-libgstdashdemux_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) $(GST_CFLAGS) $(LIBXML2_CFLAGS)
+libgstdashdemux_la_CFLAGS = \
+ $(GST_PLUGINS_BAD_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(LIBXML2_CFLAGS)
libgstdashdemux_la_LIBADD = \
$(top_builddir)/gst-libs/gst/uridownloader/libgsturidownloader-@GST_API_VERSION@.la \
- $(GST_LIBS) $(GST_BASE_LIBS) $(LIBXML2_LIBS)
+ -lgsttag-$(GST_API_VERSION) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(LIBXML2_LIBS)
libgstdashdemux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstdashdemux_la_LIBTOOLFLAGS = --tag=disable-static