summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2007-11-13 16:41:55 -0800
committerKeith Packard <keithp@koto.keithp.com>2007-11-13 16:41:55 -0800
commit8a3dc4880c1182ea446cdbc0885e956c6517cf83 (patch)
treec319ed320f396d4d3e490c1d8aab1b2a1d2c28bb /configure.in
parent1315db01b626aedd27e3e05bde96ce46c253629b (diff)
Workaround for stat() brokenness in Microsoft's C library (bug 8526)
Fix a couple of longstanding problems with fontconfig on Windows that manifest themselves especially in GIMP. The root cause to the problems is in Microsoft's incredibly stupid stat() implementation. Basically, stat() returns wrong timestamp fields for files on NTFS filesystems on machines that use automatic DST switching. See for instance http://bugzilla.gnome.org/show_bug.cgi?id=154968 and http://www.codeproject.com/datetime/dstbugs.asp As fccache.c now looks at more fields in the stat struct I fill in them all. I noticed that fstat() is used only on a fd just after opening it, so on Win32 I just call my stat() replacement before opening instead... Implementing a good replacement for fstat() would be harder because the code in fccache.c wants to compare inode numbers. There are no (readily accessible) inode numbers on Win32, so I fake it with the hash of the full file name, in the case as it is on disk. And fstat() doesn't know the full file name, so it would be rather hard to come up with a inode number to identify the file. The patch also adds similar handling for the cache directory as for the fonts directory: If a cachedir element in fonts.conf contains the magic string "WINDOWSTEMPDIR_FONTCONFIG_CACHE" it is replaced at runtime with a path under the machine's (or user's) temp folder as returned by GetTempPath(). I don't want to hardcode any pathnames in a fonts.conf intended to be distributed to end-users, most of which who wouldn't know how to edit it anyway. And requiring an installer to edit it gets complicated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c431dcc..3f7e8bf 100644
--- a/configure.in
+++ b/configure.in
@@ -459,7 +459,11 @@ AC_ARG_WITH(cache-dir, [ --with-cache-dir=DIR Use DIR to store
case $fc_cachedir in
no|yes)
- fc_cachedir=`eval echo "${localstatedir}/cache/"${PACKAGE}`
+ if test "$os_win32" = "yes"; then
+ fc_cachedir="WINDOWSTEMPDIR_FONTCONFIG_CACHE"
+ else
+ fc_cachedir=`eval echo "${localstatedir}/cache/"${PACKAGE}`
+ fi
;;
*)
;;